Corrupt CF card, software isn't working...

by ktshadley - 4/3/12 8:54 PM

Hi all,

I have a huge problem with one of my CF cards. I had a shoot on Sunday where the card worked perfectly, I looked at all of the photos on the camera during and after the shoot, and all looked good. By the time I got home and tried to upload the files that evening, the card had gone haywire. It would no longer load on the camera (it was just a black screen, wouldn't even load the menu with the card inserted. Tried this on two cameras, so it definitely wasn't a camera issue) and tried to upload them to the computer. It initially recognized that the card was inserted and I could see the files, but I couldn't see thumbnails and couldn't open the files or load them from the card.

So far, I've tried PhotoRescue, CardRaider, Stellar Phoenix Photo Recovery, and ZA Recovery, and none of them worked. Most of them wouldn't even recognize that the card was inserted.

Now, I've read on a couple of forums that I should try to format the card and then the recovery software might be able to recover the files from the formatted card, but I'm nervous to do that. What should my next step be?