I have finally cured the problem with my laptop's touchpad!

With assistance and information from our son, I stopped the jumping cursor. I have a Sony Vaio laptop running Vista and Microsoft Windows office premium.

The classic cure for the jumping cursor on-line is to disable it and use a mouse. I don't like mice so that was unacceptable.

Go to Control Panel (classic view)>system>hardware>device manager>mouse devices> You will find the touchpad listed as a mouse device. I first searched for new drivers and didn't find any. I finally disabled it (uninstall). I then had to shut down and reboot. When I rebooted Microsoft reinstalled, and I had to shut down and reboot again.

It worked and my cursor no longer jumps, but I admit that I had grave doubts about uninstalling it. Hope it works for you