SOLVED

OK, I've solved the problem. When you click 'Print' from MS Word, there's a window with the list of your printers, where PDFCreator must be choosen. Than click on 'Properties' (still on the level of MSWord), and 'Advanced' in the window that appears. There's an option of print quality set by default on 600 dpi.

When this value is increased to 720 dpi or any larger, printing from pdf file results in a good quality text, which is indistinguishible from what is printed directly from MS Word.