PostgreSQL Multiple Vulnerabilities

by Carol~ Moderator - 4/4/13 12:11 PM

In Reply to: VULNERABILITIES / FIXES - April 04, 2013 by Carol~ Moderator

Release Date : 2013-04-04

Criticality level : Less critical
Impact : Security Bypass
Brute force
Where : From local network
Solution Status: Vendor Patch

PostgreSQL 8.x
PostgreSQL 9.x

A weakness and two vulnerabilities have been reported in PostgreSQL, which can be exploited by malicious users to conduct brute force attacks and bypass certain security restrictions and by malicious people to cause a DoS (Denial of Service).

1) An error when parsing server command-line switches can be exploited to damage or destroy files within the server's data directory via a specially crafted connection request containing a database name and render the service unusable.

This vulnerability is reported in versions prior to 9.2.4, 9.1.9, and 9.0.13.

2) The weakness is caused due to an error when using the contrib/pgcrypto functions, which leads to weaker than expected random numbers being generated.

Successful exploitation requires that the postmaster is configured with "ssl = on".

This weakness is reported in versions prior to 9.2.4, 9.1.9, 9.0.13, and 8.4.17.

3) An error in the core server component does not properly handle REPLICATION privilege checks for current user and can be exploited to call the "pg_start_backup()" or "pg_stop_backup()" functions and stop the creation of routine backups.

This vulnerability is reported in versions prior to 9.2.4 and 9.1.9.

NOTE: Additionally, two weaknesses exist in the graphical installers for Linux and Mac OS X, which can lead to symlink attacks and the superuser password being disclosed.

Update to version 9.2.4, 9.1.9, 9.0.13, or 8.4.17.

Provided and/or discovered by:
The vendor credits:
1) Mitsumasa Kondo and Kyotaro Horiguchi, NTT Open Source Software Center.
2) Marko Kreen
3) Noah Misch

Original Advisory: