WordPress Click to Copy Grab Box Plugin ZeroClipboard Two

by Carol~ Moderator - 3/12/13 4:53 AM

In Reply to: VULNERABILITIES / FIXES - March 12, 2013 by Carol~ Moderator

WordPress Click to Copy Grab Box Plugin ZeroClipboard Two Cross-Site Scripting Vulnerabilities

Release Date : 2013-03-12

Criticality level : Less critical
Impact: Cross Site Scripting
Where : From remote
Solution Status : Unpatched

Software: WordPress Click to Copy Grab Box Plugin 0.x

Description:
Henri Salo has discovered two vulnerabilities in the Click to Copy Grab Box plugin for WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed via the "id" parameter to wp-content/plugins/click-to-copy-grab-box/lib/ZeroClipboard.swf and wp-content/plugins/click-to-copy-grab-box/lib/ZeroClipboard10.swf is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerabilities are confirmed in version 0.1.1. Other versions may also be affected.

Solution:
No official solution is currently available.

Provided and/or discovered by:
Henri Salo

Original Advisory:
Henri Salo:
http://www.openwall.com/lists/oss-security/2013/03/10/2

http://secunia.com/advisories/52482/