WordPress Simple Login Log Plugin Multiple Vulnerabilities

by Carol~ Moderator - 1/15/13 10:39 AM

In Reply to: VULNERABILITIES / FIXES - January 15, 2013 by Carol~ Moderator

Release Date : 2013-01-15

Criticality level : Moderately critical
Impact : Cross Site Scripting
Manipulation of data
Where: From remote
Solution Status : Vendor Patch

Software: WordPress Simple Login Log Plugin 0.x

Description:
Multiple vulnerabilities have been discovered in the Simple Login Log plugin for WordPress, which can be exploited by malicious users to conduct script insertion attacks and by malicious people to conduct script insertion and SQL injection attacks.

1) Input passed via the "redirect_to" parameter and "User-Agent" HTTP header to wp-login.php is not properly sanitised before being used. This can be exploited to insert arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site if malicious data is viewed.

Successful unauthenticated exploitation requires the "Log Failed Attempts" setting to be enabled (disabled by default).

2) Input passed via the "where" GET parameter to wp-admin/users.php (when "page" is set to "login_log" and "download-login-log" is set to "true") is not properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

The vulnerabilities are confirmed in version 0.9.3. Prior versions may also be affected.

Solution:
Update to version 0.9.4.

Provided and/or discovered by:
Reported by the vendor.

Original Advisory:
Simple Login Log:
http://wordpress.org/extend/plugins/simple-login-log/changelog/
http://plugins.trac.wordpress.org/changeset/650397/simple-login-log

http://secunia.com/advisories/51780/