Eventy Cross-Site Scripting and SQL Injection

by Carol~ Moderator - 11/13/12 11:41 AM

In Reply to: VULNERABILITIES / FIXES - November 13, 2012 by Carol~ Moderator

Eventy Cross-Site Scripting and SQL Injection Vulnerabilities

Release Date : 2012-11-13

Criticality level : Moderately critical
Impact : Cross Site Scripting
Manipulation of data
Where : Froom remote
Solution Status: Unpatched

Software: Eventy 1.x

Description:
Vulnerability Lab has reported multiple vulnerabilities in Eventy, which can be exploited by malicious people to conduct cross-site scripting and SQL injection attacks.

1) Input passed via the "id" parameter to eve_event.php is not properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

2) Input passed to the "selyear" and "selmonth" parameters in eventy.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerabilities are reported in version 1.8. Other versions may also be affected.

Solution:
No official solution is currently available.

Provided and/or discovered by:
Ibrahim El-Sayed (the_storm), Vulnerability Lab.

Original Advisory:
Vulnerability Lab:
http://www.vulnerability-lab.com/download_content.php?id=756

http://secunia.com/advisories/51246/