WordPress Plugin Quick Post Widget Cross-Site Scripting

by Carol~ Moderator - 7/5/12 6:57 AM

In Reply to: VULNERABILITIES / FIXES - July 05, 2012 by Carol~ Moderator

WordPress Plugin Quick Post Widget Cross-Site Scripting and Cross-Site Request Forgery Vulnerabilities

Release Date : 2012-07-05

Criticality level : Less critical
Impact : Cross Site Scripting
Where : From remote
Solution Status : Unpatched

Software: WordPress Quick Post Widget 1.x

Description:
Stefan Schurtz has discovered some vulnerabilities in the Quick Post Widget for WordPress, which can be exploited by malicious people to conduct cross-site scripting and cross-site request forgery attacks.

1) Input passed via the "quick_post_title", "quick_post_content", and "quick_post_new_cat" parameters to index.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

2) The application allows users to perform certain actions via HTTP requests without performing proper validity checks to verify the requests. This can be exploited to e.g. publish quick posts or conduct script insertion attacks when e.g. a logged-in administrative user visits a specially crafted web page.

The vulnerabilities are confirmed in version 1.9.1. Other versions may also be affected.

Solution:
No official solution is currently available.

Provided and/or discovered by:
Stefan Schurtz

Original Advisory:
http://www.darksecurity.de/index.php?/218-SSCHADV2012-016-WordPress-Plugin-Quick-Post-Widget-1.9.1-Multiple-XSS-vulnerabilities.html

http://secunia.com/advisories/49798/