One presumes that you computer

functions normally and that it boots correctly.

Now take a look at Finder > Preferences > General Tab

Make sure that there is a check mark in all of the items under "Show these items on the desktop:" line.

Any better?

P