I can't enter Bios. Can someone please help?

by AbbeyDabbyDoo - 3/21/12 5:45 AM

Long story short, my hard drive crashed (at least I think and hope thats what it is. ) I bought a new hard drive and am trying to install it.

This is what happens (the same thing happened before which is why I bought a new HD)

I press my power button.

A blue screen comes up (<F10-setup> <<esc=boot menu><F11= system recovery> <F9=diagnostics>)

And it stays at the blue screen

No matter what I do.

I've tried pressing F9, F10, F11 and esc continuously right after powering on. (sometimes it does say "entering setup..." but it never does anything. Just stays on the blue screen.

I have also tried resetting CMOS by removing the battery, and also by moving the small blue plug (I'm sorry I'm no pro, I don't know correct terms half the time.

Maybe 3 times it has come up with a black screen but I can't remember what it says. something about setting the boot drive or something like that.


Here is what I have:

HP Pavilion p6214y PC

windows7

NVIDIA GeForce 9100

and I just bought a WD 1T sata III hard drive to replace my WD 1T Sata HD.

Thanks for any help. I appreciate it!