WordPress SolveMedia Plugin Cross-Site Request Forgery

by Carol~ Moderator - 1/29/13 11:17 AM

In Reply to: VULNERABILITIES / FIXES - January 29, 2013 by Carol~ Moderator

Release Date : 2013-01-29

Criticality level : Less critical
Impact : Cross Site Scripting
Where : From remote
Solution Status : Vendor Patch

Software: WordPress SolveMedia Plugin 1.x

Description:
Junaid Hussain has discovered a vulnerability in the SolveMedia plugin for WordPress, which can be exploited by malicious people to conduct cross-site request forgery attacks.

The application allows users to perform certain actions via HTTP requests without performing proper validity checks to verify the requests. This can be exploited to e.g. change the Solve Media API Keys when a logged-in administrative user visits a specially crafted web page.

The vulnerability is confirmed in version 1.1.0. Prior versions may also be affected.

Solution:
Update to version 1.1.1.

Provided and/or discovered by:
Junaid Hussai

Original Advisory:
http://illsecure.com/code/Wordpress-SolveMedia-CSRF-Vulnerability.txt

http://secunia.com/advisories/51927/