I FOUND THE SOLUTION!

I was going CRAZY because, like you said, the picture on my new Samsung 65" LED tv looked like a soap opera, lacked cinematic quality and reminded me of a low-budget documentary. I changed the settings to this and it fixed it:

Below you'll find the settings we found best for viewing the Samsung UN46C6500 in a dark room via the HDMI input with a 1080p, film-based source. Your settings may vary depending on source, room conditions, and personal preference. Check out the Picture settings and calibration FAQ for more information.
http://news.cnet.com/8301-17938_105-9996461-1.html

--Picture menu

Mode: Movie
Backlight: 9
Contrast: 93
Brightness: 44
Sharpness: 0
Color: 48
Tint: G50/R50

Eco Solution submenu:
Energy Saving: Off
Eco Sensor: Off
No Signal Power Off: Off

Auto Adjustment and Screen submenus: [Grayed out]

Advanced settings submenu
Black tone: Off
Dynamic contrast: Off
Shadow Detail: +2
Gamma: +1
Expert Pattern: Off
RGB Only Mode: Off
Color space: Auto
White Balance [see below]
10p White Balance: On
Flesh tone: 0
Edge enhancement: Off
xvYCC: Off
LED Motion Plus: Off

White balance submenu
R-Offset: 25
G-Offset: 23
B-Offset: 25
R-Gain: 25
G-Gain: 25
B-Gain: 19

10p White Balance submenu
Interval 1: Red 0, Green 1, Blue 0
Interval 2: Red 0, Green 0, Blue 0
Interval 3: Red 0, Green 0, Blue 0
Interval 4: Red 0, Green 0, Blue 0
Interval 5: Red 0, Green -1, Blue 0
Interval 6: Red 1, Green 0, Blue 0
Interval 7: Red 0, Green -1, Blue -1
Interval 8: Red 0, Green -2, Blue 0
Interval 9: Red 0, Green -3, Blue -1
Interval 10: Red 2, Green -1, Blue 0

Picture options submenu
Color tone: Warm2
Size: Screen Fit
Digital Noise Filter: Off
MPEG Noise Filter: Off
HDMI black level: Normal [grayed out]
Film mode: Off [grayed out]
Auto motion plus: Custom
-- Custom settings:
Blur reduction: 10
Judder reduction: 0
Auto Protection Time: 2 hours