Fixed!

by bfalke1 - 10/26/12 5:12 PM

In Reply to: Same Problem by bfalke1

I got on Samsung help/chat and was given a solution, not sure if anyone is still having this problem, but the fix for my player was that the internet country was wrong. I am not sure ho this got defaulted to the wrong country, but it was not set to the US (and I was not given an option to select during initial setup).

If you open the smart hub, then it FF > 2 > 8 > 9 > RW (in sequence, not at once, and not next chapter, last chapter, but FF/RW), you will then be given a list of "internet countries" to select, pick USA and you can download Netflix no problem.