WordPress Cimy User Manager Plugin "cimy_um_filename"

by Carol~ Moderator - 10/24/12 12:19 PM

In Reply to: VULNERABILITIES / FIXES - October 24, 2012 by Carol~ Moderator

WordPress Cimy User Manager Plugin "cimy_um_filename" Arbitrary File Disclosure Vulnerability

Release Date : 2012-10-24

Criticality level : Moderately critical
Impact : Exposure of system information
Where : From remote
Solution Status : Vendor Patch

Software: WordPress Cimy User Manager Plugin 1.x

Description:
Charlie Eriksen has discovered a vulnerability in the Cimy User Manager plugin for WordPress, which can be exploited by malicious people to disclose certain sensitive information.

Input passed via the "cimy_um_filename" parameter to e.g. index.php is not properly sanitised in the "cimy_um_download_database()" function (wp-content/plugins/cimy-user-manager/cimy_user_manager.php) before being used to read files. This can be exploited to disclose the content of arbitrary files via directory traversal sequences.

The vulnerability is confirmed in version 1.4.1. Other versions may also be affected.

Solution:
Update to version 1.4.2.

Provided and/or discovered by:
Charlie Eriksen via Secunia.

Original Advisory:
http://plugins.trac.wordpress.org/changeset/615423/cimy-user-manager/trunk/cimy_user_manager.php

http://secunia.com/advisories/50834/