WordPress Spider Calendar Plugin "many_sp_calendar"

by Carol~ Moderator - 10/24/12 11:03 AM

In Reply to: VULNERABILITIES / FIXES - October 24, 2012 by Carol~ Moderator

WordPress Spider Calendar Plugin "many_sp_calendar" Cross-Site Scripting Vulnerability

Release Date : 2012-10-24

Criticality level : Less critical
Impact : Cross Site Scripting
Where : From remote
Solution Status : Vendor Patch

Software: Wordpress Spider Calendar Plugin 1.x

Description:
Han Lee has discovered a vulnerability in the Spider Calendar plugin for WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed via the "many_sp_calendar" parameter to wp-content/plugins/spider-calendar/front_end/bigcalendar.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerability is confirmed in version 1.1.0. Other versions may also be affected.

Solution:
Update to version 1.1.1.

Provided and/or discovered by:
Han Lee via Secunia.

http://secunia.com/advisories/50981/