Got it solved guys!!

I had the same problem. I would sign into messenger live and then click on my inbox where I would be taken to the hotmail sign in... I had recently started using more than one browser because internet explorer had issues with my google account. Therefore internet explorer was not my "default"browser. So try this...

Open internet explorer. Click on "tools". Click on "internet options". Click on "programs". Click on "make internet explorer the default browser". Hit "apply" and close the window. Close explorer and go back to messenger and click inbox. You should be back in business!!