Best answer as chosen by user Shippou5: Two possibilities

First try this. Disable hardware acceleration from within any Flash video window. Right click the video area, select "Settings", then remove the tick for "Enable hardware acceleration". Just once will change it for all browsers.

If that doesn't work, uninstall Flash using Adobe's own Flash uninstaller, reboot the computer, then revisit Adobe's web site to reinstall Flash.

Here is Adobe's Flash uninstaller - http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

You don't say if this computer is Mac, Linux, or Windows. The options above are for Windows and may be different for other OSes.

Mark