Just a hunch.

by R. Proffitt Moderator - 6/24/12 3:20 PM

In Reply to: Kindle connection help by mtlenzen

We had similar issues with Smart TVs and the fix for that was to change the DNS.

Did you try setting the router to Google DNS?

Here's how -> https://developers.google.com/speed/public-dns/docs/using

Given the details in your post I can't offer much. There are other reasons but here it works fine.
Bob