You should still ...

check that you have the latest supported version of Java installed. You can access it from the link you were provided but try this one instead as it will CHECK the version for you:
http://java.com/en/download/testjava.jsp

This link takes you to download and installation instructions:
http://java.com/en/download/help/windows_manual_download.xml

You still need to CLEAR your browser's cache and probably need to adjust the cache settings for IE 8. Try this:

1. Click on Tools menu and select Internet Options.

2. In the middle of the window that opens on the General tab click on the Delete button then make sure that ONLY Temporary Internet files and Form data are checked.

3. Click the Delete button (after deletion that window closes)

4. Now click the Settings button in the middle of the page of the General tab of Internet Options

5. Select the Automatic radio button and set the Disk Space to use for the cache to somewhere between 20 and 50 meg (more than that can be counter productive and cause problems displaying files in the cache - probably what you are experiencing)

6. Click the OK button after making the changes and OK your way out of the Internet Options dialog.

7. SHUT DOWN then re-open all instances of Internet Explorer and your image problem should be gone UNLESS it is a setting you have made in your Firewall (Zone Alarm was noted for this behavior).