This worked for me on Windows 7 Dell Laptop running FF 5

This solution worked for me (Dell E6320 laptop running Firefox 5 on Windows 7 Pro) immediately:
Go to Options > Advanced > General and uncheck the "Use hardware acceleration when available"

I found it here: https://support.mozilla.com/en-US/questions/764278#question-reply

It's a pity that you might be slowing the rendering somewhat, but the tradeoff is well-worth it...