Just a suggestion

Hi! I can be a little late but I am Spanish as well and I am interested in the same thing.
I have a Samsung B series TV which is suffering from the same "issue". After a lot of researching, the best thing I achieved is to have the second audio language set as default for those channels who broadcast the second one tagged as "V.O."
What you need to do (hopefully it also works in C series TV) is:

1) Set your country to "Other"

2) and set English as your first and second audio language in preferences (or any other, the important thing here is not to select Spanish).

After that, you'll be enjoying series and movies in their original version by default (once again, it only works for those channels whos tagged the second audio as "V.O." so if the second audio appears as "undefined", it definitely won?t work).

Before set your country to "Other", back up your channel list to an USB so you can restore it afterwards, because otherwise you'll have to tune the TV again.

And sorry for my poor English!