one of the suggestions worked for me

after many discussions with Dell...and no luck, i had a machine that would not go into sleep when plugged in...so i used the suggestion by fungi008 (see above)...and it totally worked

here it is:

Vista's dumb multimedia sharing option is the issue: Do this:
Control Panel -> Power Options -> Change plan settings (for the chosen power plan) -> Change advanced power settings -> Scroll down to Multimedia settings -> Choose "Allow the computer to sleep

That's it..hope it helps someone

BCY123