Re: redirect and rundll problem

The rundll-problem is easy to solve. From the Start button, run msconfig, go to the startup tab and uncheck that particular line.

It's not bad, and it isn't making your computer slow, but it feels better. The cause is that that malware made that line (so it would run at startup); you removed the malware program (the dll) but you didn't yet remove the line instucting windows to run it. Malwarebytes doesn't do it for you, so you have to do it yourself as outlined above. In fact, it's a good sign: it shows the malware program has gone!

If "malware and other viruses" keep appearing and you don't succeed in removing it, the best thing to do is go back to factory settings as instructed by Dell (most probably: via ctrl-f11 during boot). Then your clean again, as clean as when you first used the machine a week ago.
Be sure to apply all Windows security patches (hotfixes) from Windows update before you do anything else. And then change your surfing and browsing habits to NOT download malware and you'll be fine in the future. Getting this within a week shows you're not prudent enough. Personally, I use the Internet for years already without ever getting a virus.

Kees