Solved (hopefully

Finally talked to AT&T and they gave me HTC helpline number - 877.878.6944. Explained my problem and the guy quickly suggested I try this: On the phone,
Start Settings Connections (at bottom) then
Chose USB to PC icon
Then uncheck the box Enable advanced network functionality

Seems to work now on both PC's