Clear "Enable write caching on the disk" check box

by KauaiBilly - 6/28/09 8:02 AM

In Reply to: Vista won't sleep by anunes

I also tried all these other suggestions, but none worked. Here's what (finally) worked for me:
Open Device Manager (Control Panel > System and Maintenance > Device Manager).
Expand the "Disk Drives" list.
Right-click each hard drive, and then choose Properties.
Choose the Policies tab.
Clear the "Enable write caching on the disk" check box.

Hope this helps someone.