Try this

by Phenomx4 - 12/8/08 6:51 PM

In Reply to: Vista won't sleep by anunes

It's most likely caused by Windows Media Player.

Open WMP and find the settings that allows WMP to search for shared files. Turn off File Sharing and that should let Vista sleep in High Performance Mode.

It worked for me...so I'm sharing my success.

VM