File Saving Solution for WP 10 works for WP 8

Disable the Enhanced File Dialogs in Word Perfect.
Click on Tools --> Settings --> Files

Uncheck Use enhanced file dialogs. Click Apply --> OK

You should be able to save files again

*Note Corel WordPerfect Suite 8 installed perfectly on Vista Home Premium- HP Desktop a6013q

*Note Run WP8 as Administrator before changing above setting.