Re: typing replaces selection

The first issue is a standard problem, that we see about every two months. Go into Tools>Options>Edit and check Typing replaces selection.
Sometimes, it gets unchecked and then you get what you see.

Please tell if the second issue persists after this change.

Kees