Many web pages are not printer friendly. I've tried setting the display to a higher setting reducing the width and it still prints the same.

The best way when printing web pages is to first check print preview under the File drop down menu before printing and if the right side doesn't show, you need to change to landscape printing. Click on File menu then print and go to printer preferences or properties depending on your printer. There should be a tab or box choice for Layout where you can choose landscape over portrait. Then when printing the full width of the page will show.

Some printers do not change back once you choose landscape so to print in portrait again you should check the properties before the next printing.