Other suggestions for our community members

Answer:

Anup, here are a few things you can try which may help alleviate your problem.

Rule # 1: It is best to have backups of all your data and programs prior to attempting any of the below suggestions. Actually, it is wise to always create backups of your critical data and have your program software at hand in case you encounter any system problems. It is better to be safe then sorry. I have run into similar situations such as the one you are encountering and although it took some time to rebuild I did recover everything on my machine.

Bring up MS DOS and try running Scandisk (before Windows is loaded on your system). You may have to boot from an MS DOS disk (Startup Disk) and running Scandisk from the command line. Although the proper utility to run on Windows XP is CHKDSK/X (where X is the Drive) running Scandisk may clear the flag which is telling Windows there is an error on your drive (D: drive in your case).
You can also try the System Restore function / Last Known Good Configuration. To do this you must boot in Safe Mode and use XPs built-in System Restore function to restore the system to an earlier working configuration. Before you do this I suggest you hit the F8 key during boot up time and try the Last Know Good Configuration. If you havent been able to properly log on since you started seeing the Scandisk errors this exercise could restore the last properly working configuration you had.
Note: In order to gain access to the System Restore Wizard in Windows XP: click Start -> Help and Support. Click Performance and Maintenance; click Using System Restore to undo changes, and then click Run the System Restore Wizard.
You can also boot from the Windows XP CD and try the repair option or try fixing the master boot record by typing FDISK /MBR at the DOS Prompt.
Please go back up and read Rule #1 prior to attempting any of the above. Good Luck!

Submitted by: Joe V.

***********************************************************************

Answer:

I ran into this issue a couple of years ago and was able to find a solution on the Internet.
Here are a few resources to go on that helped me.

Chkdsk Runs Each Time That You Start Your Computer
http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q316506

Running Chkdsk to Repair File Systems
http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prkd_tro_xudm.asp

Manually resetting AUTOCHK.EXE for a drive
http://searchwin2000.techtarget.com/tip/1,289483,sid1_gci990696_dbg1,00.html

my computer wants to do a scandisk before windows loads. Is there an option to turn that off?
http://forums.sudhian.com/messageview.aspx?catid=81&threadid=63496

Try to cancel checkdisk at every boot up but unsuccessful
http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20698249.html

Good luck.

Submitted by: J.C.

***********************************************************************

Answer:

I would say to this Question
to take the program out of your startup settings so that it does not open, one can open the program manually when needed to do a scan for Problems.
There are probably lots of programs that are opening at startup that
are not needed at that particular time, so a good idea to shut them all down.

Submitted by: Jock of Melbourne. Australia

***********************************************************************

Answer:

Anup,
I am not an expert, however you may try this. My OS is Win 98 SE. I tried it and succeeded.
Even though we shut down the system properly, when we reboot, it says the system was not properly shut down and check for errors in each drive. This is really a pain in the neck. What is the reason for it. My meagre knowledge says that some information from the virtual cache has to be recorded on the hard disk, but, instead it was recorded only on onboard cache. When you shut down the system, what is recorded on onboard cache is erased. So, what is to be recorded on the hard disk is not recorded. Hence when you bootup, the system could not find the information on the hard disk(from virtual memory) while shutting down last, it assumes that the system was not properly shut down and starts the scanning of all partitions.
To avoid this, you have to edit the registry. Open the registry(start>run>regedit) and go to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
Current Version, on the right you will find 'Cache Write Delay' - there you create DWORD and give its value as 2000. Then you double click it.
Now you will not face the scan disk problem every time you boot. I repeat, this I have tried in Win 98 SE.
I advise you back up your registry and try this.
Wish you good luck.


Submitted by: Bhogaraju R. of Visakhapatnam, India

***********************************************************************

Answer:

Re: ScanDisk running at startup.

The 'error message' you receive may be incorrect.

First, check how you have this program scheduled to run.
It may be scheduled to run each time the system is booted.
Change to another option and hopefully that would solve the problem.

Submitted by: Kathleen K.

***********************************************************************

Answer:

Check to see if you have update KB894391 on your machine. This may NOT come in as part of the automatic update process, and MAY solve your problem.


Submitted by: George O.

***********************************************************************

Answer:

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'AutoScan=' to:
AutoScan=0 : Scandisk is Disabled
AutoScan=1 : Scandisk Prompts First
AutoScan=2 : Scandisk Runs Automatically Changes will take place on the next reboot.

Note: It is advisable to run Scandisk after an incorrect shutdown to avoid file corruption.

Note: This feature is only available on Windows 95 OSR 2 and greater.

Submitted by: Ken S.

***********************************************************************

Answer:

Hi. I suppose that you have a problem with Hard Disk Partitions Definitions in drive D. I suggest that you must backup all important data from your drive D and reformat all Drive (C an D). The format proccess notice you if you have some tracks bad (perhaps its containe information about bad partition D) and you may resize your drive for best results.

I hope that it was helpful for you.

Submitted by: Mario S.

***********************************************************************

Answer:

If the user is using Norton SpeedDisk, he may have inadvertently checked View/Global Options/Scan For Errors Before Optimizing NTFS Volumes.
That will lock the C: drive on booting so that the drive can be scanned before Windows boots. If so, unchecking that box should solve his problem.


Submitted by: Norman H. of Azalea, OR

***********************************************************************

Answer:

ou might check the Start-Up Menu ... you may have accidentally dragged the ScanDisk icon into the Start-Up Folder (Start, Programs)


... Best regards,

Submitted by: rix rox

***********************************************************************

Answer:

Scandisk

Ive had the same problem on my PC (Windows 2000) I cured it by scheduling a check disk on the next boot. After it ran I did not have anymore unwanted disk checks. This has happened a few times and scheduling a check disk always stops the problem. I use Norton Systems works, but the windows check disk also works.


Submitted by: Jim I.

***********************************************************************

Answer:


I don't know how to stop the original problem, but I do know how to stop the scandisc process.

When the scanning begins, hit the "enter" key and the scanning will stop and the normal booting will continue.

But since you do have some sort of problem with the shutdown process, I would allow the scandisc to run to completion every fifth boot or so. It may just find a problem eventually.

P. S.
Do not shut off the computer with the button on the CPU.
Use the "shutdown" in the start menu. If it hangs at the "Windows flag", then you can use the CPU button, at that point. If you do all of this, the scandisc will not start.

P.P.S.
If you do this to the point of pushing the start/off button on the CPU, hold the button till you see and hear it shut off. It takes about five to eight seconds of holding the button in the depressed position before it shuts off.

If you are only using the CPU button to shut down your computer, that is your problem. This will cause the scandisc to run everytime you reboot (restart) the computer.
When you see the message stating that the computer was shutdown improperly, that is what it means. DO NOT just use the button on the CPT to shut off your computer. Use the "shutdown" in the start menu.
I think that is all I have to contribute. Hopefully.

Submitted by: RJT of Fort Lauderdale, FL.