Many Need To Perform These Steps

Here's a link with a registry edit which fixes your sharing issue. (It probably won't cure the "Public Folders" problem as they're designed to stay where there are.) Although the overall discussion is regarding Windows XP, it works for Windows 7 too, as indicated by the last poster in the thread, who stated that you will need to create the new Dword value as shown in option 4..

http://forums.cnet.com/7726-6122_102-3230783.html

Hope this helps.

Grif