An: Added a Netgear Range Extender thats when the fun starte

Try this link when connected through the extender;

http://www.mywifiext.net/cgi-bin/hidden_dhcpd.html


enable and it should let you chnage the range to outside the parameters of your current DLink and avoid conflicts;