Same issues - firmware upgrade killed my internet@TV

I completed the firmware upgrade after my blu-ray player refused to play new blu-ray releases. The screen came up on loading a movie informing me I must complete the firmware upgrade before I can watch the movie.
So I ran a network cable direct to the player and did the update. After the update my Internet@TV stopped working.
I contacted chat support and was asked to do two troubleshooting steps.
1. unplug unit for 30 seconds
It did not correct the issue.
2. hold stop button on remote for 10 seconds
It did not correct the issue.
Here is an excert from my chat.

Firware version: BSP-C5500WWB-1027.0
Nadal :
Please try to unplug and replug the unit and check if the issue persists.
Steve Cracknell :
screen is blank, blu-ray says ONLINE
Nadal :
Please ry to Reset the player and check if the issue persists.
Nadal :
Press and hold the Stop or Play/Pause or FF button on the player for 10 seconds to Reset player.
Steve Cracknell :
I am back, it did not work
Steve Cracknell :
still blank TV, blu-ray says online
Steve Cracknell :
there is no disk in the player
Nadal :
As the issue persists after all troubleshooting steps, there might be some internal issue with the unit, please examine the unit physically by a service technician for the root of cause.
Steve Cracknell :
Do I have a case ID with you?
Nadal :
No we do not have any Case ID, but you can get back to us with the same email address for our future reference.

And that is where I stand now....a broken blu-ray player and no fix other than a new one.