Philips 42PF7320A - Black Screen and Blinking Red LED

by dantrimble - 1/21/09 6:42 PM

In Reply to: Same Problem!!! by manderson4038

My Philips HDTV is 2 years old, maybe 2 and a few months at most. It's worked fine until yesterday. Now, it begins to power up, does not show anything on the screen, I get a blip or two of audio, and then I hear the click as it powers off. Once it does that, the green LED goes red, and blinks in patterns of 7 rapid red blinks, followed by a few seconds of no blinking, and then repeats.

Philips told me it "might" be an electrostatic discharge. They also said it "might" be old firmware (which I can't upgrade since I have no screen to access the upgrade menu). They also said it "might" be something else, but they "are not qualified" to tell me what, precisely. I've been instructed to bring it to a repair place for diagnostics. I live in the San Francisco Freakin Bay Area -- in Fremont no less, a city of 250,000 people and they're telling me two closest places to take it are in Oakland (31 miles) and San Jose (39 miles)!

I'm LIVID. No television should last 2ish years before going out, especially one that was nearly $2,000. This is ridiculous.

Has anyone else had this problem? If so, can you tell me what the problem was, the cause, and what had to be done to repair it? I'd like to get some more insight into the potential issues and problems before I drag the thing for repairs.

Also, if any body has had any luck getting Philips to spring for the bill after the warranty ran out on the grounds that this is an absurdly huge problem to have on a still very-new television, I'd love to hear how.


@#&^*@^#!@#*^!&@#^*!@#&^% grumble...


Dan