Car Tech forum: 1997 JEEP GRAND CHEROKEE LIMITED STALLING AND DYING PROBLEM,

by: anderson9700 August 30, 2011 3:43 PM PDT

Like this

1 person likes this thread

Staff pick

Resolved question

1997 JEEP GRAND CHEROKEE LIMITED STALLING AND DYING PROBLEM,

by anderson9700 - 8/30/11 3:43 PM

My wife and I have owned this Jeep Grand Cherokee Limited, straight 6,
4x4, since it had 95k on it. It was a single owner vehicle and well
maintained.

We've maintained it perfectly and always ensure that it is
in for its fluid changes early. Nearly 6 years later, it now has
approximately 144k on it.


About a year and a half ago it began cutting out now and then. It would
just die. However, you could restart it without fail. Then it began to
die while coming to a stop. Then it began to die at idle. Then it began
to die while driving on the freeway and highway at much higher speeds.

That's the progression.

We've read numerous forums and the like and have
notated the information we found therein. I recall reading a few posts
made by members of these forums stating that they had spent every dime
they had over a 6 month period trying to fix it, now they are broke and
without transportation because it won't start, they can't afford to fix
it, the mechanic is clueless, and we thought, ... well, (cough, cough),
we won't be one of those guys. Ha.


We have replaced all of the typical causes for such behavior and a few other things, to no avail.

Here's a list of what we have replaced and done thus far:


Compression & Leakage Test (three times): Passed with perfect mesurement.
Spark plugs
wires
distributor cap
rotor
pick up coil
coil
power
steering pump
both O2 sensors (front and back)
timing sensor (on the block)
crank
shaft position sensor
fuel pump (complete assembly with the filter
included)
two hoses top-side of the engine block
PVC valves on top of
the engine
the MAP/MAFS sensor
throttle position sensor
idle control
module
hand cleaned what little carbon build up was in the Throttle Body.
checked all hoses for leaks numerous times
replaced the coolant
temperature sensor
replaced the battery
replaced the battery cables
checked all connections numerous times
checked for the correct readings
on all sensors and they all check out.
PCM
BCM

Now, some of that, our mechanic has done. Never-the-less, here we are. And still with NO CHECK ENGINE LIGHT.

He's said that he's thoroughly checked the harness to the PCM and
verified everything is properly grounded. He doesn't believe that it has
anything to do with the connections or the wiring. He said that there
are only two things left. The PCM and the BCM. Both are on-board
computers.

We've spent all of our savings and current cash flow on this vehicle at this point. Its been
down for over a week. We haven't even paid our bills at this point. I'm self employed and when I'm not driving, I'm
not making money.

This is a critical moment in my life as I don't have
enough money to purchase another vehicle right now.

Chrysler took a look at it once and said that they didn't see anything
wrong. I haven't taken it back as that was a fruitless effort and pricy.

My wife ran into a Chrysler mechanic of thirty years the other day and
he said that we ought to check the valve springs.

However, that didn't
seem right to me because it would seem like you would hear it rattle.
When I forwarded that information to our mechanic, he assured me that if
it were the valve springs, that it would be a noticeable noise. There is
no such noise.

Sometimes it just dies, sometimes it'll sound like its choking a bit
while it dies or while it comes close to dying. Sometimes it dies at
idle, sometimes while driving slow, sometimes at high rates of speed,
sometimes while stopping.

There does not appear to be any consistency
with it. It does not make any unusual sounds. When it originally began,
it was just hard to start a couple of times and then for the first few
months, seemed to only want to die when coming to a stop. Now it can be
hard or very hard to start, and it will die unexpectedly with no check
engine light or other signs of problems.

There is one exception to the engine light. On two occassions while
driving at 50+ mph and climbing in elevation (long hills like going into
the mountains), it would choke a bit, and then give a check engine
light. However, it never died. When I connected the OBD 2 sensor to it,
it read: CYLINDER 2 MISFIRE DETECTED.

So, my question to anybody who is a mechanic, anybody that works for
Chrysler, anybody who has ever owned a Jeep and experienced a similar
issue.

Do you have any idea what the cause could be and the best way, at this point, to resolve the issue and/or where to go from here?

Is it likely to be the Catalytic Converter?

ADDITIONALLY:
MECHANIC: JUST TODAY - Replaced the crankshaft position sensor .... again. No avail. Same thing. Runs for awhile and then dies.

Everything is as it should be according to the diagnostics and computer readings. I've talked to a few shops and they are all clueless.

Mechanic also advised that he's talked to other mechanics he knows, a couple of specialist, a former Chrysler Technician, and some other shop owners in California that he knows, and they are all clueless at this point. He said that he thought whatever it is that's causing the problem is most likely something small because it doesn't have any issues with the engine and most all other parts have been replaced now. ~ Doesn't make me feel better.

Recommended that I bring it to the dealership for further review.

I'm stuck and cannot afford to go to the dealership. PLEASE HELP!

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close

You are requesting a clarification of the question: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Submit Clarification Request Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close

You are posting an answer to the question: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Submit Answer Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close
close

Click here to be notified via e-mail when someone submits an answer.

Would you like to resolve this question? close

Based on your response, it looks like this question has been answered.



Sorry, there was a problem resolving this question. Please try again.

Resolve Leave unresolved