MP3 players forum: PC Not recognizing MTP Device... HELP PLEASE!!!

by: pedrossi24 March 17, 2007 2:44 PM PDT

Like this

0 people like this thread

Staff pick

PC Not recognizing MTP Device... HELP PLEASE!!!

by pedrossi24 - 3/17/07 2:44 PM

I bought a Zen V Plus 4gb yesterday, got home and installed everything from the CD, but when I connected my Zen and the program tried to register it, it said it found no unregistered components. I ignored it and tried to open the Media Manager to add songs. It said there's no player connected. I opened Windows Media Player and clicked 'Sync' and there's no player there, either. Every time I connect the player, a Windows Wizard comes up asking me if I want to connect to the internet to install the driver for it. I tried clicking 'yes' once, but it said it couldn't find any drivers. I checked the Device Manager and it says there's a Creative Zen V connected but there's a yellow warning icon next to it. I've tried reinstalling the software from the CD 4 times, and restarted my PC numerous times as well. My player does seem to be charging, as I left it connected to the PC for about 2 hours and now when I disconnect it the battery display is about 1/3 of the way full.

I tried the troubleshooting on Creative's website, but no luck. I also tried a fix that seemed to be working for a lot of people with this problem, which was modifying the registry permissions for USB. I did that, but still no luck.
I'm running Windows XP Service Pack 2, 768mb ram, 2.8Ghz Pentium 4 on an HP Pavilion a410y machine.

This is an interesting development: my dad got one of these (a 1gb Zen V) for his birthday, and installed all the software on his PC (an HP Pavilion, different model than mine, 512 ram, 3.0ghz pentium 4). He succeeded in putting all his songs on my player, so I decided to try his PC, since he already had all the software. His PC's Media Explorer recognized my player... and my player can play the radio and everything, so I'm guessing the problem is with my PC.

Any ideas? Thanks in advance!
Edit/Delete Message

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close