PC hardware forum: KVM switch problems

by: revdrjm January 28, 2004 11:33 PM PST

Like this

0 people like this thread

Staff pick

KVM switch problems

by revdrjm - 1/28/04 11:33 PM

operating systems - Win XP Pro + Linux (various 9.xx releases)
Belkin 2-Port KVM Switch with built in cabling.F1DK102P
Cordless Logitech Desktop Pro key board and mouse.

Connecting the hardware together as per the manual, and booting either (or both) machine(s), the keyboard and mouse will not respond. The KVM is connected to the PS/2 ports and the keyboard and mouse are connected with USB to PS/2 connectors to the switch.
One sytem connected alone will operate fine, the problem is only apparent when both machines are connected. The monitor output is not effected but cannot switch between machines. The cables on both sides of the switch work fine and are not damaged in any way. The switch is 1.5 months old. I am using default MS drivers for the mouse and keyboard, configured as standard/generic MS devices under linux. I am not using any Logitech software to control either device, Belkin says not to.

When I first installed the switch there were no problems switching between the two machines. I have rolled back the configurations to make sure there are no other programs or drivers that were not present when the switch was first installed. Also with both machines connected the keyboard is unresponsive in the BIOS setup.

I have seen a reference to a similar problem attributed to a grounding problem (diagnosis for this problem made by Belkin) on a forum on the web, but this was for a different switch a while back.

I opened the switch to make sure there were no internal broken leads, connections, or visible shorts. This most likely means a can't send it back to Belkin should it prove to be an otherwise unsolvable problem, oh well.

I sent an e-mail to Belkin support but have yet to hear from them, so I ask you all here.

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close