Networking & wireless forum: Problem connecting Samsung TV to wi-fi via repeater

by: vellasta July 5, 2012 2:20 AM PDT

Like this

0 people like this thread

Staff pick

Resolved question

Problem connecting Samsung TV to wi-fi via repeater

by vellasta - 7/5/12 2:20 AM

I have posted this in the Samsung manufacturer's forum, but not sure if that's the right place so i'm posting it here as well....

I have this strange problem connecting my Samsung tv to my network. Let me state the facts...

A. TV is a Samsung LCD C750 2010 model.
B. I am using the Samsung wi-fi dedicated dongle
C. My modem/router (2 in 1) is a Thomson Technicolor TG582n

Now,

1. With repeater switched off, the TV can see the wireless network, but the signal is very very low. Still, when it manages to catch the signal, I run the network test on the TV and the 4 steps run successfully. Internet apps work, however they soon fail due to very low signal.

2. I recently bought an Xbox, placed just next to the TV, and it simply wouldn't detect the signal... so I bought an Edimax EW-7416APn which I have configured as a Universal Repeater.

3. The Xbox now works perfectly fine, and indeed all my other wireless devices like laptops, mobiles etc.. are working perfectly with the new Edimax repeater - the strongest possible signal, full networking and internet functionality.

4. Then I thought, now that I have a repeater, why not try connecting the TV again through it. So I browse for networks, find my homenetwork in the list (showing an excellent signal, now that it is being detected from the repeater), select it, and enter the pass phrase.

5. I run a network test on the TV and:

MAC Address test: passes

IP/DNS test: passes

Gateway ping: FAILS


The TV has acquired an IP, so there is communication with the repeater and indeed with the router which has provided the TV with an IP address. I can even ping that IP address from my laptop (which is connected via cable directly to the router) - so definitely, there is some kind of communication between the TV and the router and the TV is indeed on the network. However, I've tried millions of combinations and the network test simply fails on the Gateway Ping.

I have tried with/without security, changing channels and a number of other settings, but to no avail. I have tried manual settings on the TV... setting a fixed IP just outside my DHCP range (192.168.1.251), subnet mask 255.255.255.0, and gateway and DNS server IPs to those of my router (192.168.1.254).

Since the TV connects fine (when it manages to do so due to weak signal) to my router, I tend to point my finger at my Edimax repeater.
However, since all other devices are happily connected to the repeater, I then tend to point my finger at the TV!
Or perhaps at the combination of both!

Any idea what I else I could try?

P.S. using cable is out of the question and moving the modem/router to bring it closer to the TV is out of the question too, due to my home layout.

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close

You are requesting a clarification of the question: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Submit Clarification Request Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close

You are posting an answer to the question: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Submit Answer Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close
close

Click here to be notified via e-mail when someone submits an answer.

Would you like to resolve this question? close

Based on your response, it looks like this question has been answered.



Sorry, there was a problem resolving this question. Please try again.

Resolve Leave unresolved