Storage forum: problems with external hard drive

by: 4JohnW July 9, 2006 6:07 AM PDT

Like this

0 people like this thread

Staff pick

problems with external hard drive

by 4JohnW - 7/9/06 6:07 AM

I have an external hard drive which has worked fine for the pass 4 months. However, now the computer simply could not detect it. Usually there would be the USB icon and autoplay on windows when I connect the hard drive, but now, nothing pops out. I have also tried to use the add hardward under the control panel icon in the start button, but the icon for the hard drive was not there. I have checked the hard drive for any obvious physical damage, but I think the hard drive works fine since I can hear it spinning inside.

On the enclosure there are two LEDs; one marked as "LED" and another one as "R/W". Usually during autoplay or when there hard drive is reading, the "R/W" lights would be flickering. But now, it doesn't.

I am using windows XP
The hard drive is a 120 gb Maxtor
The enclosure is a ZDisk external storage from Cintre (model CI-330U2)

My question is this:

Is the hard drive or the enclosure is the problem since I can still hear and feel the hard drive is spinning but the "R/W" led on the enclosure is not flickering.

If the enclosure is the problem, I can simply replace it. But if the hard drive is damaged, I would lose all my pictures sad

Please help me. Thank you!

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close