Wireless Internet forum: D-Link DWLG-122 USB adapter can't connect at all

by: SteveMcGarrett February 9, 2007 7:39 AM PST

Like this

0 people like this thread

Staff pick

D-Link DWLG-122 USB adapter can't connect at all

by SteveMcGarrett - 2/9/07 7:39 AM

I purchased a DI-524 router and DWLG-122 USB Wireless adapter together and was able to set up the router easily. I had no problem picking up the wireless signal on my laptop anywhere in the house, but when I attempted to install and use the USB adapter it will not work.

I've installed the latest firmware update, but it still reports that it cannot find a wireless network, even though my laptop is sitting right next to it and reports that the signal strength is excellent.

I've uninstalled and reinstalled numerous times without ever having the USB adapter pick up the signal.

The people I've talked to on the tech support line were very difficult to understand and I have a hard time believing that this can be that difficult as it should be a straightforward plug and play type of solution.

I have not changed any factory defaults so I'm thinking this may be a hardware failure.

I'm running XP Pro w/ SP2. I've tried connecting using both XP's Wireless Config and w/ the D-Link config w/o any success. It's not even "seeing" the network, let alone configuring it. The D-Link utility icon is just white bars and it's bombs almost immediately when I search for wireless networks.

My laptop saw it and connected immediately right away so it can't be signal strength or encryption. My next step is to borrow a different USB adapter from a friend who no longer uses theirs to see if that would make any difference. I don't think it's firewall related as it doesn't even get that far along in terms of trying to connect to the net.

Any help you can offer would be most appreciated!

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close