FYI: Firefox 5, Flash Player 10.x Win2k OK

by sdfox7 - 6/11/11 8:09 AM

Firefox 5 beta has been released, and the Firefox 5 system requirements page shows Windows 2000 as an officially supported operating system.

I'm also not having any problems with Windows 2000 and Flash on my test system.

Firefox 5 System Requirements

http://www.mozilla.com/en-US/firefox/5.0beta/system-requirements