Resolved question

Problem with Airport Extreme and Leopard 10.5.8

by staubert - 3/31/12 7:21 AM

I'm operating leopard 10.5.8 on my imac7,1 with an Intel Core 2 Duo and I have over 2gb of memory available. I want to install an airport extreme in my home but when I clicked on airport utilities is said that I can't open the application because it is not supported on this architecture. What do I do? How can it not be supported? Do I need to upgrade to snow leopard?
HELP!!!