Sony forum: Sony Poor Design Problems

by: MrJTP2010 September 13, 2010 9:29 AM PDT

Like this

0 people like this thread

Staff pick

Sony Poor Design Problems

by MrJTP2010 - 9/13/10 9:29 AM

I bought a Sony STR-DE845 tuner/amp about 7 years ago. After about 2 years of use it began to have issues. I would occasionally turn the bass to max, drop a speaker, etc. The the on/off switch quit working forcing the use of the remote to turn it on and off. Then I noticed that if you selected the A speakers or the B speakers you always got both on any setting. It continued to get worse until I replaced it last week. Based on my background I thought I would try to do a failure analysis.

Sony uses a stacked circuit board approach where connector pins on the 'motherboard' (they label it as the DISPLAY board) insert into sockets on other boards which are mounted above the motherboard. Since most of the problems seemed to be associated with the power switch and speaker select switch I pulled that board and found nothing apparently wrong with it.

However, when I examined the mating connector on the mother board, under magnification, it became apparent that the solder joints on 4 of the 5 pins had failed. (yes, I have photographs) The type of failure where solder on the pin has separated from the solder on the circuit board is frequently associated with mechanical shock/vibration or thermal cycling.

This type of failure, where the solder joint fails, usually leads to intermittent problems which is exactly what I was experiencing.

After photographing the failure at these pins I checked the other similar connector for the "MUTING" circuit board. Again 3 or the 5 pins had solder connection failures.

Mechanical causes of the failures can probably be ruled out since the unit has been sitting in the same place since it was wired into my system. Thermal expansion/contraction 'might' be the cause due to the large operating swing from room temperature to 'very hot' after operating for a couple of hours.

This type of failure should have been discovered during environmental testing at Sony, if they have such a program. The solution would have been to select a connector which provided more physical support for the connector pins on the motherboard. The connector sockets on the 'daughter boards' had good physical support and did not show any failures.

Looking back I have owned several Sony products and don't recall any of them lasting more than 5 years. I have tended to ignore this because when one failed I was anxious to replace it with a newer, more high tech, feature rich unit. Maybe Sony depends on that attitude.

Forum Icon Legend

  • UnreadUnread
  • ReadRead
  • Locked threadLocked thread
  •   
  •   
  •   
  •   
  •   
  •   
  •   
  • ModeratorModerator
  • CNET StaffCNET Staff
  • Samsung StaffSamsung Staff
  • Norton Authorized Support TeamNorton Authorized Support Team
  • AVG StaffAVG Staff
  • avast! Staffavast! Staff
  • Webroot Support TeamWebroot Support Team
  • Acer Customer Experience TeamAcer Customer Experience Team
  • Windows Outreach TeamWindows Outreach Team
  • DISH staffDISH staff
  • Dell StaffDell Staff
  • Intel StaffIntel Staff
  • QuestionQuestion
  • Resolved questionResolved question
  • General discussionGeneral discussion
  • TipTip
  • Alert or warningAlert or warning
  • PraisePraise
  • RantRant

You are e-mailing the following post: Post Subject

Your e-mail address is used only to let the recipient know who sent the e-mail and in case of transmission error. Neither your address nor the recipient's address will be used for any other purpose.

Sorry, there was a problem emailing this post. Please try again.

Submit Email Cancel

Thank you. Sent email to

Close

Thank you. Sent email to

Close

You are reporting the following post: Post Subject

If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Offensive: Sexually explicit or offensive language

Spam: Advertisements or commercial links

Disruptive posting: Flaming or offending other users

Illegal activities: Promote cracked software, or other illegal content

Sorry, there was a problem submitting your post. Please try again.

Submit Report Cancel

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

Your message has been submitted and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.

Close

You are posting a reply to: Post Subject

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to the CNET Forums policies for details. All submitted content is subject to CBS Interactive Site Terms of Use.

You are currently tracking this discussion. Click here to manage your tracked discussions.

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

Sorry, there was a problem submitting your post. Please try again.

Sorry, there was a problem generating the preview. Please try again.

Duplicate posts are not allowed in the forums. Please edit your post and submit again.

Submit Reply Preview Cancel

Thank you, , your post has been submitted and will appear on our site shortly.

Close