Resolved question

How to get scanning capability back - M2335dn MFP

by char47les - 9/2/13 6:25 PM

I have a Dell 2335dn printer used with a Dell inspiron 580 running Windows 7. My computer is connected wirelessly via Airport Extreme. (There is still a USB cable from my computer to the printer, but i don't think that's how the systems communicate.) I would scan by going to "devices and printers" and clicking on my printer; it would bring up a page where I could select options to do a scan. Those options do not appear any longer; I am unable to scan through my multi-function device. I do not scan all that often, so I am not sure how long these options have been gone, but I am aware of two significant changes that may be the culprit.

The likeliest source is some attempts to clean up my computer. A while back (maybe a couple months ago) I decided to get rid of various programs that I never use; they occupy space and I would get "nags" from some of them. Some of the programs I eliminated were Dell programs - I thought the main thing of that sort that I pitched was the Dell backup programs -- since I back up everything to Mozy already. I suspect i managed to pitch my scan manager software when i did that.

I pulled up my original installation disk for the printer; deleted my 2335dn and reinstalled the original printer driver. This did not bring back my scanning software. Looking at the installation disk, there was a scan manager folder. i ran the setup.exe file in that folder and it told me that there were missing files. If I told it to "ignore" those files and proceed, the process seemed to complete, but I did not wind up with my scanning capability again.

The other possibility is if something happened when I installed the Airport Extreme - at that point I went from the USB connection for my printer to the wireless connection. This was about 3 months ago. I kind of think the first scenario is more likely the culprit (if something I did is even responsible for this).

I have tried going to the Dell website and downloading the driver for the 2335dn -- but I do not seem to be able to install it successfully by that route; I'm not sure why.

Anyone have any ideas or any suggestions?